[Lubuntu 15] Chrome browser fails to start NSS >= 3.26 is required
by Riley MacDonald, January 30, 2018

After updating some of my local packages I discovered that my Chrome browser would not start. I received no error, the application simply wouldn’t start.

I wanted some log output to determine the root cause of the issue. I tried to execute chrome from CLI. Unfortunately I didn’t know the name of the package so I used apropos to find the command:

$ apropos chrome
google-chrome-stable (1) - the web browser from Google
neotoppm (1)         - convert an Atari Neochrome .neo into a portable pixmap
openchrome (4)       - video driver for VIA Unichromes
ppmtoneo (1)         - convert a portable pixmap into an Atari Neochrome .neo file

OK, the command is google-chrome-stable. I’ll execute it and hope for some error logging output.

$ google-chrome-stable
FATAL:nss_util.cc(632)] NSS_VersionCheck(3.26) failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.

Interesting, I’m not familiar with the package or it’s name. apropos returns too much, I’ll have to search the web for it. Turns out the package is libnss3. I wonder what version I’m at:

$ apt show libnss3
Package: libnss3
Priority: optional
Section: libs
Installed-Size: 3,848 kB
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Source: nss
Version: 2:
Depends: libc6 (>= 2.14), libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>= 4.8.6), libsqlite3-0 (>= 3.5.9), zlib1g (>= 1:1.1.4), libnss3-nssdb
Pre-Depends: multiarch-support
Conflicts: libnss3-1d (<< 2:3.13.4-2)
Download-Size: 1,133 kB
Homepage: http://www.mozilla.org/projects/security/pki/nss/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m
Task: virt-host, ubuntu-desktop, ubuntu-usb, tomcat-server, kubuntu-desktop, kubuntu-full, kubuntu-active-desktop, kubuntu-active-full, kubuntu-active, edubuntu-desktop, edubuntu-usb, xubuntu-desktop, mythbuntu-frontend, mythbuntu-desktop, mythbuntu-backend-slave, mythbuntu-backend-master, lubuntu-desktop, ubuntustudio-publishing, ubuntustudio-live, ubuntu-gnome-desktop, ubuntu-sdk-libs, ubuntukylin-desktop, ubuntu-mate-desktop, ubuntu-mate-cloudtop
APT-Manual-Installed: yes
APT-Sources: http://archive.ubuntu.com/ubuntu/ vivid-updates/main amd64 Packages
Description: Network Security Service libraries
 This is a set of libraries designed to support cross-platform development
 of security-enabled client and server applications. It can support SSLv2
 and  v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
 other security standards.
N: There are 2 additional records. Please use the '-a' switch to see them.

Interesting, I’m on version I’ll try to use apt to update it.

$ sudo apt upgrade libnss3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... libnss3 is already the newest version.

I found the package on the Debian website. Since I’m still running on Lubuntu 15 the package isn’t available in the repositories of my /etc/apt/sources.list. After finding the package on the Debian org I added deb http://security.debian.org/debian-security wheezy/updates main to my /etc/apt/sources.list and retried the update. Great I’m now on libnss3 version 2:3.26-1+debu7u5. Chrome is now launching as expected. If you’re looking to resolve a similar issue be sure to grab an up to date package.

I should update my distribution.

Open the comment form

Leave a comment:

Comments will be reviewed before they are posted.

User Comments:

Be the first to leave a comment on this post!